VMWare – Upgrade VCENTER e ESXI

E então tenho um ambiente VMWare para atualizar, e agora como fazer?

Após estudo de caso, e alguns laboratórios descobri e validei que:

1 – No processo de update do ambiente VMWare, primeiro de tudo é subir a versão do VCenter.

2 – Com o VCenter numa versão superior aos ESXI, você instala o “VMWare Update Manager” na mesma maquina que o VCenter, utilizando a própria ISO de instalação dele, vai la no VSphere Cliente habilita, após isso você sobe a imagem ISO do ESXI equivalente a do VCenter, cria um Baseline com essa imagem, vai nos hosts e aplica esse update, ou seja, upgrade automatizado ao qual ele coloca o host em manutenção, roda tudo que for preciso, reinicia e BUM host atualizado e em compliance com  VCenter.

3 – O “VMWare Update Manager” somente cria imagem ESXI da versão equivalente a do VCenter, portanto monte sua estratégia para subir as versões.

4 – Caso tenha algum erro ao aplicar o baseline no ESXI, analise os logs no VSphere Client “Home > Solutions and Applicatons > Update Manager > Events” la ele te cagueta tudo o que deu de merda, “Ahh e entre no site da VMWare e analise a tabela de compatibilidade, se não vai ter a mesma surpresa que eu, um host com CPU VELHINHO não suportado pela versão.”

5 – E caso não esteje contente com o “VMWare Update Manager” que faz tudo sozinho, tem como atualizar pelo terminal do ESXI, vai no site da VMWare, baixa o pacote .ZIP “BUNDLE OFFLINE”, joga pra dentro do datastore, loga via SSH, e choraa.

Primeiro colocar em modo manutenção e remover as VMs de cima deste host:

Abaixo ao mandar o comando, tive erro de dependência:

Então, listamos os profiles:

E atualizamos profile por profile:

Ai um reboot e BUMM ESXI atualizado via terminal (8

Referências:

https://kb.vmware.com/s/article/2008939

https://www.vmware.com/resources/compatibility/

https://kb.vmware.com/s/article/392

http://vcdx56.com/2017/09/update-esxi-fails-with-dependencyerror-requirement-cannot-be-satisfied-within-the-imageprofile/

https://miketabor.com/easy-esxi-6-0-upgrade-via-command-line/